sudo gem install veewee で Unable to resolve dependencies: fog requires net-scp (~> 1.1) のエラーが出る。

症状

$sudo gem install veewee
ERROR:  While executing gem ... (Gem::DependencyError)
    Unable to resolve dependencies: fog requires net-scp (~> 1.1)

対処

$ sudo gem i net-scp --version '= 1.1' -V --no-ri --no-rdoc
GET http://rubygems.org/specs.4.8.gz
302 Moved Temporarily
GET http://production.s3.rubygems.org/specs.4.8.gz
200 OK
GET http://production.s3.rubygems.org/specs.4.8.gz
200 OK
GET http://gems.github.com/specs.4.8.gz
304 Not Modified
GET http://gems.rubyforge.org/specs.4.8.gz
302 Moved Temporarily
GET http://production.s3.rubygems.org/specs.4.8.gz
200 OK
GET http://rubygems.org/latest_specs.4.8.gz
302 Moved Temporarily
GET http://production.s3.rubygems.org/latest_specs.4.8.gz
200 OK
GET http://production.s3.rubygems.org/latest_specs.4.8.gz
200 OK
GET http://gems.github.com/latest_specs.4.8.gz
304 Not Modified
GET http://gems.rubyforge.org/latest_specs.4.8.gz
302 Moved Temporarily
/usr/lib64/ruby/gems/1.8/gems/net-scp-1.1.0/lib/net/scp.rb
/usr/lib64/ruby/gems/1.8/gems/net-scp-1.1.0/lib/net/scp/download.rb
/usr/lib64/ruby/gems/1.8/gems/net-scp-1.1.0/lib/net/scp/errors.rb
/usr/lib64/ruby/gems/1.8/gems/net-scp-1.1.0/lib/net/scp/upload.rb
/usr/lib64/ruby/gems/1.8/gems/net-scp-1.1.0/lib/net/scp/version.rb
/usr/lib64/ruby/gems/1.8/gems/net-scp-1.1.0/lib/uri/open-scp.rb
/usr/lib64/ruby/gems/1.8/gems/net-scp-1.1.0/lib/uri/scp.rb
/usr/lib64/ruby/gems/1.8/gems/net-scp-1.1.0/net-scp.gemspec
/usr/lib64/ruby/gems/1.8/gems/net-scp-1.1.0/setup.rb
/usr/lib64/ruby/gems/1.8/gems/net-scp-1.1.0/test/common.rb
/usr/lib64/ruby/gems/1.8/gems/net-scp-1.1.0/test/test_all.rb
/usr/lib64/ruby/gems/1.8/gems/net-scp-1.1.0/test/test_download.rb
/usr/lib64/ruby/gems/1.8/gems/net-scp-1.1.0/test/test_scp.rb
/usr/lib64/ruby/gems/1.8/gems/net-scp-1.1.0/test/test_upload.rb
Successfully installed net-scp-1.1.0
1 gem installed

追記

$ sudo gem i net-scp --version '= 1.8' -V --no-ri --no-rdoc
GET http://rubygems.org/specs.4.8.gz
302 Moved Temporarily
GET http://production.s3.rubygems.org/specs.4.8.gz
200 OK
GET http://production.s3.rubygems.org/specs.4.8.gz
200 OK
GET http://gems.github.com/specs.4.8.gz
304 Not Modified
GET http://gems.rubyforge.org/specs.4.8.gz
302 Moved Temporarily
GET http://production.s3.rubygems.org/specs.4.8.gz
200 OK
ERROR:  Could not find a valid gem 'net-scp' (= 1.8) in any repository
GET http://rubygems.org/latest_specs.4.8.gz
302 Moved Temporarily
GET http://production.s3.rubygems.org/latest_specs.4.8.gz
200 OK
GET http://production.s3.rubygems.org/latest_specs.4.8.gz
200 OK
GET http://gems.github.com/latest_specs.4.8.gz
200 OK
GET http://gems.rubyforge.org/latest_specs.4.8.gz
302 Moved Temporarily
GET http://production.s3.rubygems.org/latest_specs.4.8.gz
200 OK
ERROR:  Possible alternatives: net-scp
        とでた。
   

コメント

このブログの人気の投稿

pip install mojimoji failed

Windows Server 2008 R2 & PHP 5.6(64bit)